groovy:providers

Full name:

org.codehaus.groovy.maven:gmaven-plugin:1.0-rc-5:providers

Description:

Displays information about the Groovy runtime providers which are configured and selected.

Attributes:

  • Since version: 1.0-beta-3.

Optional Parameters

Name Type Since Description
providerSelection String 1.0-beta-3 A comma-seperated list of provider keys, in order of preference of selection. If the invoking JVM is at least Java 1.5, then the Groovy 1.6 runtime will be used, else the Groovy 1.5 runtime is used.

Parameter Details

providerSelection:

A comma-seperated list of provider keys, in order of preference of selection. If the invoking JVM is at least Java 1.5, then the Groovy 1.6 runtime will be used, else the Groovy 1.5 runtime is used.
  • Type: java.lang.String
  • Since: 1.0-beta-3
  • Required: No
  • Expression: ${gmaven.runtime}